从前对xcode的参数配置,从前对xcode的参数配置

近期xcode升级了5.1版本,升级之后先后报有关要适配arm64机械的错。以前对xcode的参数配置,平昔不是很掌握,但贯彻先面对难点了,就考察了瞬间并解决它。

多年来xcode升级了5.1版本,升级之后先后报有关要适配arm64机械的错。之前对xcode的参数配置,一贯不是很了然,但贯彻先面对难题了,就查明了弹指间并缓解它。

一个一个来呢。

一个一个来啊。

Architectures
那意味,在那个类型里你想要Xcode编译的靶子设备列表。
Valid Architectures
还不是太显眼那么些装置的打算,然则一般的话是不须求改变的,和Architectures一样就可以。

Architectures
那意味着,在那几个系列里你想要Xcode编译的目的设备列表。
Valid Architectures
还不是太强烈这几个设置的来意,然而一般的话是不须要改变的,和Architectures一样就可以。

在Xcode5.1里的Valid Architectures 设置里,默许为Standard
architectures(armv7,armv7s,arm64),假如你想改的话,自己在other中改变。

在Xcode5.1里的Valid Architectures 设置里,默认为Standard
architectures(armv7,armv7s,arm64),借使您想改的话,自己在other中改变。

案由表达如下:
使用standard architectures (including
64-bit)(armv7,armv7s,arm64)
参数,则打的包里面有32位、64位两份代码,

案由说明如下:
使用standard architectures (including
64-bit)(armv7,armv7s,arm64)
参数,则打的包里面有32位、64位两份代码,

在中兴5s(中兴5s的cpu是64位的)下,会首选运行64位代码包, 

在HTC5s(摩托罗拉5s的cpu是64位的)下,会首选运行64位代码包, 

其余的诺基亚(其他HUAWEI都是32位的,中兴5c也是32位), 只可以运行32位包,

别的的红米(其他华为都是32位的,HUAWEI5c也是32位), 只好运行32位包,

不过包括三种架构的代码包,唯有运行在ios6,ios7连串上。 

而是包蕴二种架构的代码包,唯有运行在ios6,ios7种类上。 

这也实属,那种打包格局,对手机大致没啥必要,然而对系统有需求,即ios6之上。
而使用standard architectures
(armv7,armv7s)
参数, 则打的包里只有32位代码, 金立5s的cpu是64位,然则足以匹配32位代码,即可以运行32位代码。但是那会下滑金立5s的属性。 其他的华为对32位代码包更没难题, 而32位代码包,对系统也大约也没怎么范围。
据此统计如下: 

那也就是,那种打包形式,对手机大约没啥须要,可是对系统有须要,即ios6以上。
而使用standard architectures
(armv7,armv7s)
参数, 则打的包里唯有32位代码, One plus5s的cpu是64位,不过足以匹配32位代码,即可以运行32位代码。不过这会骤降一加5s的习性。 其他的魅族对32位代码包更没难题, 而32位代码包,对系统也几乎也没怎么范围。
因此统计如下: 

要发挥中兴5s的64位品质,就要包含64位包,那么系统最低要求为ios6。 假设要包容ios5以及更低的系统,只好打32位的包,系统都能通用,不过会丧失一加5s的性能。

要表明索爱5s的64位品质,就要含有64位包,那么系统最低须求为ios6。 如若要包容ios5以及更低的连串,只好打32位的包,系统都能通用,不过会丧失One plus5s的特性。

Build Active Architecture Only

Build Active Architecture Only

本条特性设置为yes,是为着debug的时候编译速度更快,它只编译当前的architecture版本。
而设置为no时,会编译所有的版本。
其一是设备对应的architecture:

那个特性设置为yes,是为了debug的时候编译速度更快,它只编译当前的architecture版本。
而设置为no时,会编译所有的本子。
其一是设备对应的architecture:

armv6:iPhone 2G/3G,iPod 1G/2G
armv7:iPhone 3GS/4/4s,iPod 3G/4G,iPad 1G/2G/3G
armv7s:iPhone5, iPod5
arm64:iPhone5s,ipad air,ipad mini2

armv6:iPhone 2G/3G,iPod 1G/2G
armv7:iPhone 3GS/4/4s,iPod 3G/4G,iPad 1G/2G/3G
armv7s:iPhone5, iPod5
arm64:iPhone5s,ipad air,ipad mini2

编译出的本子是向下包容的,比如您设置此值为yes,用iphone4编译出来的是armv7版本的,iphone5也得以运作,然而armv6的配备就不可以运行。
于是,一般debug的时候可以选用安装为yes,release的时候要改为no,以适应不一致装备。

编译出的版本是向下兼容的,比如您设置此值为yes,用iphone4编译出来的是armv7版本的,iphone5也可以运行,不过armv6的装备就无法运作。
于是,一般debug的时候可以拔取设置为yes,release的时候要改为no,以适应不相同装备。

经过对上述参数配置的刺探,我解决了难点。

通过对以上参数配置的问询,我解决了难题。

xcode5.1你的主次一旦援助了arm64,那么您的持有静态库或者framework都要匡助才得以,所以您要重复编译三遍。

xcode5.1你的先后一旦辅助了arm64,那么您的具备静态库或者framework都要帮衬才方可,所以你要再度编译三遍。

刹这间是参考博客:

转眼间是参照博客:

http://my.oschina.net/shede333/blog/172785

http://my.oschina.net/shede333/blog/172785

 

 

http://www.bkjia.com/IOSjc/764675.htmlwww.bkjia.comtruehttp://www.bkjia.com/IOSjc/764675.htmlTechArticle最近xcode升级了5.1版本,升级之后程序报关于要适配arm64机器的错。之前对xcode的参数配置,一直不是很了解,但实现先面对问题了,就调查

相关文章